Our website would like to use cookies to store information on your computer. You may delete and block all cookies from this site, but parts of the site will not work as a result. Find out more about how we use cookies.

Login or Register

Powered by
Powered by Novacaster
File loss mystery solved -- RAID array (array) is forgiven
by Bruce Ure at 10:31 26/10/07 (Blogs::Bruce)
This one didn't lose me anything crucial -- luckily.

(This is quite a dull read; it's more of a quick bit of therapy for me).

I'm sure everyone tecchie is similar. When I work on computers I do a subconscious risk assessment when I shuffle stuff around, balancing effort against consequences of data loss.

Yesterday I was trying to clear TV programmes off my Mac Mini so that I could record more TV programmes (there's a problem right there warranting its own analysis, but some other time) so I connected to my main server machine and rather than Copy the files and then Delete them, I decided that for simplicity's sake I'd Move them.

Big mistake.

At the back of my mind something was telling me to be careful, because there was an independent copy process going on on the destination drive already which was nearing completion, but I told myself it didn't matter, because it was simply copying files to the destination drive from another drive on the same server.

So off it went.

Then about half way through, Pathfinder threw up an error message, so I Skipped, then immediately another error message, and so on until there were no files left to be copied.

Oh great, I thought. The source files are fucked.

But on closer inspection, turned out the entire destination directory was missing.

Great, I thought. The new RAID controller's fucked. All the aggravation I went through to set up the RAID in the first place was a waste of time because how can I trust a device which randomly removes directories on a whim? This does not bode well.

But then the other process, which my brain had urged me to consider before I started the Move, and which had taken about 6 hours, finished, and something clicked.

I'd selected a Smart Update, because 6 hours prior I'd not considered that I'd be using the new RAID drive in anger until it had finished.

So it had come to the relevant part of its operation, and deleted the directory I'd just created and started moving my telly programmes into, because it wasn't on the source drive it was Smart Updating from.

Fuck fuckity fuck.

I could have tried File Scavenger (or whatever its equivalent is for OSX) to undelete the files, but life's too short... and this was never more clearly demonstrated than by the fact it was surplus unwatched TV programmes I was shuffling.

Hey ho.

On the plus side, the RAID controller's off death row and back on probation.


<< Slightly worrying extra menu i... Evolution >>
Printer Version