Our website would like to use cookies to store information on your computer. You may delete and block all cookies from this site, but parts of the site will not work as a result. Find out more about how we use cookies.

Login or Register

Powered by
Powered by Novacaster
Mac, Take 2
by Bruce Ure at 10:25 05/06/06 (Blogs::Bruce)
Despite my deep-seated belief that Macs are overhyped, overpriced and over here, I have taken the plunge once more by the acquisition of an incredibly sexy Mac Mini.
This may illustrate several things:

I hate Microsoft so much I'm prepared to try a Mac again even after a disastrous foray into the world of Powerbooks.

I get bored easily.

It's possible I didn't try hard enough before.

I want a PVR solution and I so bady don't want to build it with Windows. Besides, the remote that comes with the Mac Mini to drive Front Row is so sexy it's almost worth the price tag of the entre computer on its own. I thought it was a complimentary ipod Shuffle when it fell out of the box.

And there we have it. So far I'm already happier with the sensible keyboard of a proper Mac than I was with the daftly-designed Powerbook keyboard (and don't get me onto that sodding can't-override-sleep-when-closed 'feature'), and this one also seems much more responsive, but then with an Intel dual core wossname instead of a primitive G4 you might expect that, even though this one has half the memory.

The only two irritations so far encountered apart from the usual at-sign-double-quotes layout abomination, and the weird text selection keys, are not being able to use the same shortcut to go to the Firefox address bar (Windows' alt-D), which is admittedly extremely minor, and the fact that when you copy (or move) a folder into a folder where there is already a folder of that name, it DELETES the destination folder before copy/moving the new one, rather than MERGE them which is what I was expecting to happen. Is it purely my Windows background that makes me think merge is a much more sensible option?

OK, perhaps I should have finished reading the message that began something like "This folder already contains a folder called that. Do you want to " before pressing whatever I pressed, but hey.

Actually three irritations, and this one's pretty major. If I go to Network I can see my windows machines, but if I double-click them despite authenticating with known-good user/pass, I get the ubiquitous (everyone else with a windows box and a mac seems to have this issue) message "The alias 'whatever' could not be opened because the original item can not be found'".

Well YOU PUT IT THERE, why can't you find it??

Hang on, actually 4 irritations. The mouse acceleration profile is all wrong. Same mouse as Windows machines (MS - actually their mice are damn good), same manufacturer's drivers (MS), different acceleration. Slow/tiny cursor movements are much more laboured, need much bigger movements of the mouse. Very annoying, and there seems to be nothing I can do about it except get used to it. I've tweaked the mouse settings and increasing the sensitivity high enough that small movements react quicker makes it far too sensitive for big movements. Ho hum.

I've actually seen this behaviour on other mice on Windows machines, but not been able to pin it down to anything in particular, just a vague feeling that it's to do with "acceleration".


<< Preserve a snowflake forever This is amazing >>
View Comments (Threaded Mode) Printer Version
Mac, Take 2 Bruce Ure - 10:25 05/06/06
Re: Mac, Take 2 Bruce Ure - 10:54 05/06/06
Hmmm, smart folders.

Is this another example of expectations not living up to reality?

Create smart folder, of all files on a particular [network] drive with name ending '.flac'. Wait 30 seconds while it populates. Go and do something else for a few minutes. revisit smart folder. Wait 30 seconds while it populates again.

Is this abuse?

Should I just make a shortcut, sorry alias, to my flac folder?

Just a pondering, not a criticism as such.


Re: Mac, Take 2 Simon - 11:27 05/06/06
So let me see, you create a smart folder (which is essentially a canned search) for the contents of a network drive (presumably Windows hosted) and are complaining that it takes 30 seconds to refresh the contents?

How is it supposed to know whether something's updated the content on the network drive without checking the timestamps/filesizes/checksums of everything contained therein? That's going to take some time and depend on speed of your network and the speed of the network host.

I've got a smart folder called 'CIOT anything this month', which looks for any file on this Mac that contains the string 'CIOT' and was modified in the last 30 days. I've not looked at it today yet until now but it just took 3 seconds to give me back a sorted list of everything relevant. That's because Spotlight updates its database whenever stuff changes on disk.

If the network drive was Mac-hosted instead of Windows, then I _think_ I'm right in saying that the Spotlight index of the remote machine would be accessible to the local machine and so the smart folder results would come back similarly quickly for you as for me.


Re: Mac, Take 2 Bruce Ure - 11:17 05/06/06
Can't restart finder, all I did was plug in a huge usb drive and got the SBoD, mutter mutter.

Have tried various command line parameters to kill it and restart, but none seem to work in this instance.

It Just Works... apart from when it doesn't.


Re: Mac, Take 2 Simon - 11:32 05/06/06
I suppose that'd be a Mac-formatted USB drive?

Give the thing a chance, FFS, it's probably trying to index the entire contents (unless you told Spotlight not to do so for this drive).


Re: Mac, Take 2 Bruce Ure - 11:54 05/06/06
Try not to take this too personally Simon :)

The stuff I say about Macs being shite is just me bring a prat, you know this. I haven't recently bought one just so I can bash it, or rile you. I like the damn things and I am trying to approach this with the attitude of "is this an unreasonable expectation" rather than "this is shite because...", hence where I said "Is this another example of expectations not living up to reality". So please don't think I'm picking holes for the hell of it.

No, this is not a Mac formatted disc but why on earth should it not be able to cope with a big disc being plugged in? The fact it understands the format indicates that it is designed to deal with it. If Finder is really indexing 32 gigs of home movies (and about 250 gigs of other shite, but it was when I tried to change into that folder it pooed itself) then why doesn't it give me some indication that that's what it's doing?

When I went to the Finder icon in the dock, it said "Application not responding" and gave me two options: Hide and Relaunch. Hide was pointless (and didn't work anyway) and relaunch didn't. Neither did sudo reboot reboot, when all else had failed, it just sat there. Even press and holding the power switch and then back on didn't work. I had to unplug the power.

If OSX is so friendly and usable why didn't it say "indexing your massive disc you twat, have some bleedin' patience." I expected (possibly unreasonably) more intelligence than a Windows-esque "Application not responding".

I personally think there may be more to this particular problem, but I've no idea what. Maybe, as you say, it doesn't like the disc format... but that would be weird because it doesn't mind other USB drives I've plugged in.


Re: Mac, Take 2 Simon - 12:27 05/06/06
I'm just responding in kind - I'm not taking it personally :-)

'Application not responding' is new info - sounds like it doesn't like this particular disk for some reason.

Terminating the process (and pulling the plug) with extreme prejudice is unlikely to have helped though I'm afraid.

Something's causing Finder to hang, and your best bet in these situations is to command-option-escape to bring up the equivalent of Task Manager which may allow you to relaunch the Finder when the Dock-icon menu doesn't.

I'd shut the Mac down, re-plug the USB disk with a different cable and reboot with it already connected and see if that improves things.

Re: Mac, Take 2 Bruce Ure - 12:42 05/06/06
Would that have given any more control than

slippy:~ bruce$ killall -HUP Finder


slippy:~ bruce$ killall Finder && open /System/Library/CoreServices/Finder.app

or various other command lines that purport to be able to restart an atrophied Finder?

I'll jiggle with the disc a bit more once it's finished a lengthy copy operation in progress.

More info: if I mount the massive drive from OSX as a windows share it deals with it all fine. If I try and boot with it plugged in to the Mini, it won't boot (on one out of one occasion -- will try again shortly).

Thanks for your assistance :-)


Re: Mac, Take 2 Simon - 12:48 05/06/06
If you're typing that exactly as is in a terminal window, then you may have better luck if you prepend 'sudo'.

But it might be something that the Finder's waiting on, so killing it alone may not be enough. My money's still on Spotlight racing through the disk trying to set up its database of meta-info.

Before you plug it in again, fire up Activity Monitor and watch the 'All Processes' list when you connect the drive. Does anything shoot to the top and stay there?' (click the column heading to sort by CPU %).

Re: Mac, Take 2 Bruce Ure - 12:59 05/06/06
I don't remember it asking for a password when I entered the commands so I don't think I used sudo. Would it do nothing, or complaint that I didn't have rights, if sudo was needed but forgotten?

Unless sudo is a once-per-session thing, because I've a feeling I had used it earlier on.

I wonder if I can tell Spotlight not to index the USB drive I'm about to plug in :-)

Presumably one can disable spotlight, plug the drive in, tell spotlight not to index that specific drive, then switch spotlight back on again.

Although I remain concened about the machine-won't-boot-with-drive-plugged-in scenario.

One quite elegant way round this might be to replace the Mini's internal drive. Is it SATA, do you know? Cos I've a half terrabyte SATA drive sitting here...


Re: Mac, Take 2 Simon - 13:11 05/06/06
The only way to tell Spotlight not to index something is to have that something available first, unfortunately. A utility called 'Spotless' will allow you to globally disable it though (and other funky things)

Are you sure there's no filesystem corruption involved - have you checked it under Windows?

Just a thought - this wouldn't happen to be something previously shared off a Windows box to the Mac that you've now connected locally?

Off the top of my head, I don't know the spec of the Mini drives - they're probably 2.5" IDE or SATA (they're usually laptop-equiv drives, 4200rpm and low power).


Re: Mac, Take 2 Bruce Ure - 13:23 05/06/06
> Are you sure there's no filesystem corruption involved - have you checked it under Windows?

Yes it's fine.

> Just a thought - this wouldn't happen to be something previously shared off a Windows box to the Mac that you've now connected locally?

It would, yes.


Re: Mac, Take 2 Simon - 14:02 05/06/06
Hmm - I wonder if the system's confused about that.

If you inspect the volume under Windows, are there any files/folders called:

Network Trash Folder

... or similar present (like a load of files called ._something.ext)

I'm wondering whether deleting (via the Windows machine) any existing Mac-related meta-data on the disk might help. This is purely a shot in the dark, mind you.

I only have one SMB-mountable device here (internal disk on an ancient Win98 laptop) and can't test whether moving that to a USB-connected local device causes problems for me.

Another thought - anything in /var/log/system.log relating to failed mounts of the USB disk? You can get to all these logfiles via the Console app.


Re: Mac, Take 2 Bruce Ure - 14:18 05/06/06
Weird. I stopped spotlight and restarted the machine, then plugged in the disc. All was fine. So I rebooted with the drive plugged in... all was fine.

So I ejected the disc, unplugged it, started spotlight, restarted the machine, plugged the disc back in, all was fine... nothing going mental in activiy monitor. Navigated up, down, all over the place through the drive structure, all was still fine.

So I restarted the machine with the disc plugged in, all was fine.

And all still is--touch wood.

Only changed variables are: there are loads more files on the disc now; and I used a different, shorter, cable to connect the drive up.

I've not encountered cable issues with USB before, except a dodgy ribbon cable in an external USB HDD enclosure, but that looks the most likely explanation.

Which is good, because if this kind of behaviour had been caused by spotlight I'd have been mightily unimpressed :-)

Cheers again Simon.


Re: Mac, Take 2 Simon - 15:15 05/06/06
Glad it's sorted.
Re: Mac, Take 2 Gordon Hundley - 18:38 05/06/06
Wish I'd seen this sooner. Can I just say "I hate Spotlight with a passion" here?

Here's what I do on all my Mac stuff:

vi /etc/hostconfig

(line should now say "SPOTLIGHT=-NO-")

mkdir ~/.disabled
mv /System/Library/CoreServices/Search.bundle ~/.disabled

mdutil -i off /
mdutil -E /

Now Spotlight will not start, there will be no Spotlight icon in the menu bar, and you'll have cleaned up any space used for indexes. Life is better, disk operations are faster and removable media doesn't stall the system.

When I need a full text search archive, I'll assign a box just for that. I certainly don't want it on my live systems.

Oh, and another tip for success - get TextMate. Then you can invoke it from the command line instead of vi.

Re: Mac, Take 2 Simon - 17:28 06/06/06
The thing that annoys me about Spotlight is that it will not give me accurate results.

I can see there's a bazillion files called 'blah.vcf' in my attachments folder, due to all the Outlook people including their vCards on every email, but will Spotlight find them if I put ".vcf" (without the quotes) in the little search box in the folder's top right corner?

Will it hell.

Bizarrely, it happily finds all the 'signature.asc' files from digitally signed emails by putting ".asc" in the same search box.

sudo-fu Hugo van der Sanden - 11:55 06/06/06
I don't remember it asking for a password when I entered the commands so I don't think I used sudo. Would it do nothing, or complaint that I didn't have rights, if sudo was needed but forgotten?

You would normally get a permission denied kind of message, but it'll be application specific.

Unless sudo is a once-per-session thing, because I've a feeling I had used it earlier on.

Supplying the correct password for sudo opens a time window (by default 5 minutes) in which it won't ask you again. It's only within that terminal though.

You can close the window yourself with 'sudo -k'.


Re: sudo-fu Bruce Ure - 12:07 06/06/06
Thank you, hugo-ku.

I am becoming wiser in the ways of you-nicks.

I even used "find" yesterday. From a command prompt! And with a parameter!!


- Deleted User Account - 17:03 06/06/06
Re: Mac, Take 2 Simon - 11:45 05/06/06

Network alias not found

So what happens if you try to connect to it manually via Finder, Go Menu, Connect to Server (cmd-K)?

Does it work or do you get an error? What does the console log say?


Re: Mac, Take 2 Bruce Ure - 12:27 05/06/06
I think I've been able to adjust my mindset to making this work.

Which is another way of saying I was being an idiot.

The reason hidden shares are called hidden is because they are hidden, which means they can't be found. The clue is in the name. So the error message is OSX's way of saying "I can't find any shares on that machine."

I'd still rather it had said "I can't find any shares on that machine" instead of "The alias ... could not be opened because the original item cannot be found", which is slightly misleading. I actually thought there was a bigger problem than that it couldn't find any shares; it had that sort of feel to it.

Now I have set up visible shares (ie. with names not ending in '$') they are easily clickable and all is bliss.

Do you know if there's an easy way of asking the machine to try and reconnect an SMB share at startup? (And preferably not sulk for too long if it can't.)


Re: Mac, Take 2 Simon - 12:42 05/06/06
I very nearly suggested you were over-thinking the Mac experience, but decided against :-)

The things in the Network browser _are_ aliases, so the error message kinda makes sense - at least you know what it means now.

All you have to do to get it to login to the share at startup is open System Preferences, Accounts, Login Items and drag the share's icon from the desktop into the list.

Re: Mac, Take 2 Bruce Ure - 12:50 05/06/06
Thanks, that's perfect.

The bloody thing hasn't made me a cup of tea yet :-/


- Deleted User Account - 12:53 05/06/06
Re: Mac, Take 2 Bruce Ure - 13:09 05/06/06

Have you looked at Ubuntu? Since I'm having an OS Orgy today I'm going to have a go at a permanent (as opposed to booted from CD) installation on my main Windoze box, seeing as it's basically a passive file server these days. Regrettably I will still need a windows machine in my life and that will be my VAIO laptop, but I might even dual-boot that or Ubuntu it and run windows in VMWare.

This slow erosion of Windows, this two-forward-one-back-ness, is good. One day I shall be Windows-free at home.


Re: Mac, Take 2 [a slight aside] Bruce Ure - 14:57 05/06/06
My brother in law just replied to a mail I'd sent in which I mention the Mini, and Ubuntu:

"Nice thought that if it doesn't work out you can always install Ubuntu on it and substitute the B for a C".

Which I thought was good :)