Our website would like to use cookies to store information on your computer. You may delete and block all cookies from this site, but parts of the site will not work as a result. Find out more about how we use cookies.

Login or Register

Powered by
Powered by Novacaster
Weird Mac LANishness
by Bruce Ure at 23:09 25/10/07 (Forum::Technical Advice::General)
I sincerely hope this will just go away when I upgrade to Leopard some time soon after tomorrow, but it's bugging me anyway because it don't make no sense.
In Finder's 'Network' item on my main machine here are various network connections listed, as you'd expect on a LAN with a number of machines.

In 'My Network' I can connect to all but one using a respectively valid username and password.

The one that I can't is called 'slippy'. When I double-click it, there's a pause of a couple of seconds, then up pops a box entitled "AFP Connection Status" with the message "Looking up ..." which sits there for about a minute before popping up another one saying "The server may not exist or is not operational at this time. Check the server name or IP address and try again".

Yet I can ping slippy from a terminal and it correctly resolves the DNS which as you might expect is 192.168.1.something.

WTF is It's not a special address is it? The only google hit on it is a "Tech Support Guy" post involving a Windows machine which has had that address auto-assigned to it.

Any ideas as to what other weirdness might be causing this?

I've tried all the usual stuff like restarting, looked in all the network configs for that ip address, tried connecting to slippy via its ip address (which works).

Weirdy beardy.


<< Let's get preloaded Weird Mac LANishness >>
View Comments (Threaded Mode) Printer Version
Weird Mac LANishness Bruce Ure - 23:09 25/10/07
Re: Weird Mac LANishness Graham Freeman - 02:45 26/10/07
You want RFC3330. It explains how that block is reserved for autoconfigs where there's no reachable DHCP server.
Re: Weird Mac LANishness Bruce Ure - 07:44 26/10/07
Coo, thanks. Surprised there's only one hit on that particular address.

But the mystery of why it's using it when there IS a reachable DHCP server, the one that assigned it the sodding 192 address, is still unsolved.


Re: Weird Mac LANishness Simon - 09:25 26/10/07
Sounds like something's cached the incorrect IP somehow.

Interestingly, if I go 'Cmd-K' in the Finder and look in the 'Recent Servers' drop down (the clock icon) I can see an afp://169.blah.blah.blah item in there. It's not an address I've added, so something's put it there automatically.

Try clearing the Recent Servers list, also have a look in your Keychain to see if there's an entry there, and remove it if so.