Our website would like to use cookies to store information on your computer. You may delete and block all cookies from this site, but parts of the site will not work as a result. Find out more about how we use cookies.

Login or Register

Powered by
Powered by Novacaster
 
PowerBook G3 Firewire RAM Upgrade Notes
by Simon at 15:26 31/07/04 (Blogs::Simon)
This article describes the process I went through to upgrade the RAM in my Powerbook from 256MB to 1GB.
Attached is an Apple PDF document describing the dismantling procedure.

This machine had 2 x 128MB SODIMMS in it (one original, one 3rd party upgrade), which have worked fine for 3 years, but 256MB isn't enough to run OS X 10.3.4 Panther properly.

I'd received 2 x 512MB SODIMMS from Crucial in the post (next day delivery for 0 as the order was over 25 - good service).

Having shutdown the PB, unplugged the power and removed the battery I dismantled the machine as described in the PDF.

I had to pull up the processor daughterboard by using an 'L'-shaped bit of plastic I had lying around as a 'hook' under the bottom right corner of it - gentle continuous pulling directly upward worked better than levering (plastic bends, you see). There's supposed to be a tab you can pull on, but there wasn't on mine.

I then removed the existing RAM and fitted the new 512MB SODIMMS - one in the top slot, one in the bottom (ie underneath the daughterboard).

Reassembled the machine, and booted. This was where it all started to go wrong.

The startup chime was as usual, but the instead of booting into OS X as normal I was presented with a blank gray screen.

There's a sinking feeling you get when you've just exerted some physical force against delicate electronic components and what worked before is no longer happy.

Out with the new RAM, back in with the original RAM, but still no joy - uh oh, have I fried my hardware? Mild (well, ok, a considerable) panic ensues. Even though all the data's backed up, I can do without the disruption of a hardware failure.

I eventually managed to get the machine up to the stage of running a minimal OS9.2 with the old RAM using a combination of:

1) Option key at startup to choose secondary partition to boot from (holding vanilla OS9.2 - boy am I glad I kept that around)

2) Extensions Manager at startup to switch all extensions off since it hung otherwise just after the start of the extensions load sequence.

(I've glossed over about an hour's worth of poking about in Open Firmware, Google, Apple's support site and UseNet to little avail trying to identify what the symptoms meant)

Suddenly, a clue appears - while casting about for other avenues I come across an article about gray screens in OS X on Apple's support site and it mentions resetting the Power Management Unit as a thing to try. So I do so (it's a tiny wee button on the back panel).

Reboot again (OS 9.2 as before), now I've got a warning popup that says there's a problem with some RAM. Strange this hasn't showed up until now, and why resetting the PMU should cause me to get a warning about RAM I don't know - but there it was.

Apple System Profile claims the SODIMM in one slot is "Not Compatible" - it's never mentioned this before. Now, I don't know which slot is which but it's easier to remove the top slot SODIMM than the bottom, so out it comes...

This time we won't boot at all - we get 3 beeps on restart. Ah, so it's the one in the bottom slot that's gone west then.

Dismantle again, put the other 128MB SODIMM in the bottom slot, rebuild, restart...

Bingo - we boot with all extensions and no errors into the secondary OS 9.2. What's more, we can boot into the OS 9.2 system on the OS X 10.3.4 primary partition too. Hooray!

Pause to snarl at removed 128MB SODIMM.

There then follows a cycle of:

Bottom Slot = 128MB, Top = 512MB = OK
Bottom Slot = 512MB, Top = empty = OK
Bottom Slot = 512MB, Top = 512MB = OK

... dismantling the machine one more time to get to the slot under the daughtercard to put the 512MB in there instead of the 128MB - but I'm getting practiced at it now.

Final step, choose the OS X primary system in Startup Disk and let's try what we first tried a couple of hours ago.

Success! Up and running again with Panther, this time with 1GB RAM giving a much more responsive experience.

>breath huge sign of relief<

S.

Attachments...
PDF file (2726 K) Powerbook G3 Manual (see p58 for access to bottom RAM slot)
<< Gosh, is it 1984 again? Chasing wild geese >>
Printer Version